C# and PictureBox not loading

This is a discussion on C# and PictureBox not loading within the C# Programming forums, part of the General Programming Boards category; Hi, I am developing a program which allows me to view a camera. The images are stored on a hard ...

  1. #1
    Registered User
    Join Date
    Feb 2011
    Posts
    2

    C# and PictureBox not loading

    Hi,

    I am developing a program which allows me to view a camera.
    The images are stored on a hard drive on a computer and i've gotten through the login etc, but when I try and display the picture, it just doesn't show.

    Here is what I am doing to show the picture:

    Code:
    MainScreen_One_Pic.ImageLocation = "http://" + port1_site_ip + ":" + port1_site_port + "/ivop.get?action=live&piccnt=1&THREAD_ID=" + port1_threadid;
    It roughly translates to:

    Code:
    MainScreen_One_Pic.ImageLocation = "http://1.2.3.4:987/ivop.get?action=live&piccnt=1&THREAD_ID=bb234897rh2y3hvr237r2h;
    If I put the URL that is generated in a web browser, the image displays perfectly.
    Am I doing something very wrong here?

    Thanks.

  2. #2
    the hat of redundancy hat nvoigt's Avatar
    Join Date
    Aug 2001
    Location
    Hannover, Germany
    Posts
    3,139
    Are you sure that this URL actually returns a "picture" or does it return an html page that has a picture on it?
    hth
    -nv

    She was so Blonde, she spent 20 minutes looking at the orange juice can because it said "Concentrate."

    When in doubt, read the FAQ.
    Then ask a smart question.

  3. #3
    Registered User
    Join Date
    Feb 2011
    Posts
    2
    It does return a picture.
    Content type is image/jpeg etc,

    I've tried it with a static image from google images, and it still doesn't work.
    I did have it working once, but then will not work again.

Popular pages Recent additions subscribe to a feed

Tags for this Thread


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21