'yvals.h' namespace error in MVC7.1

This is a discussion on 'yvals.h' namespace error in MVC7.1 within the C++ Programming forums, part of the General Programming Boards category; I just installed the 'Microsoft Visual C++ 2003 .net' edition (Thats version 7.1). After installing it, a project I had ...

  1. #1
    Registered User
    Join Date
    Nov 2007
    Location
    CT, USA
    Posts
    2

    'yvals.h' namespace error in MVC7.1

    I just installed the 'Microsoft Visual C++ 2003 .net' edition (Thats version 7.1). After installing it, a project I had worked on in Linux and wanted to port to Windows compiled just fine. After compiling I got a message that windows update had a 'service pack 1' for the IDE and I decided to upgrade. Now, after having upgraded, I get the following error when trying to compile the same program (no code has changed):

    Code:
    c:\Program Files\Microsoft Visual Studio .NET 2003\Vc7\include\yvals.h(116) : error C2143: syntax error : missing ';' before 'namespace'
    c:\Program Files\Microsoft Visual Studio .NET 2003\Vc7\include\yvals.h(116) : error C2501: 's' : missing storage-class or type specifiers
    In my project, I am utilizing the Xerces-c XML parsing library and, in getting it to work with this IDE, I had to goof around with the project settings. I have a feeling that the issue lies there somewhere but as it worked before compiling, I truly have no idea what the problem could be (not to mention that it's a problem with the IDE's include files itself!)

  2. #2
    Registered User
    Join Date
    Nov 2007
    Location
    CT, USA
    Posts
    2
    I'm sorry, please ignore this post. It was a dumb mistake on my part. Apparently my fingers must have slipped somewhere and a:

    Code:
    /* */
    comment was changed to an

    Code:
    /* */s
    (The 's', obviously, should not have been there)

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. namespace problem
    By DL1 in forum C++ Programming
    Replies: 8
    Last Post: 10-17-2008, 12:10 PM
  2. global namespace errors
    By stubaan in forum C++ Programming
    Replies: 9
    Last Post: 04-02-2008, 03:11 PM
  3. We Got _DEBUG Errors
    By Tonto in forum Windows Programming
    Replies: 5
    Last Post: 12-22-2006, 04:45 PM
  4. Post...
    By maxorator in forum C++ Programming
    Replies: 12
    Last Post: 10-11-2005, 08:39 AM
  5. data validation & namespace
    By tiange in forum C++ Programming
    Replies: 4
    Last Post: 07-05-2005, 02:45 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21