I can't get profiling to work with Visual Studio 6

This is a discussion on I can't get profiling to work with Visual Studio 6 within the C++ Programming forums, part of the General Programming Boards category; I'm using Microsoft Visual C++ 6 for my development environment. I've been able to get profiling to work in the ...

  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    580

    I can't get profiling to work with Visual Studio 6

    I'm using Microsoft Visual C++ 6 for my development environment. I've been able to get profiling to work in the past...I'm aiming at getting just basic function timings to see where bottlenecks in my physics simulation program are occuring.

    In order to get profiling to work, it is my understanding that you have to follow these steps:

    -Go to Project->Settings
    -In the settings menu, go to Link
    -In the Link folder, go to the General category (in the drop down menu)
    -Make sure 'enable profiling' and 'generate mapfile' are checked
    -Rebuild entire project
    -Go to Build, then Profile

    The problem is that no matter how many times I do these steps, 'Profile' is grayed out meaning something is still setup incorrectly. I'm very perplexed at this problem. Any ideas?
    Last edited by Darkness; 12-30-2004 at 04:58 PM.

  2. #2
    Registered User
    Join Date
    Dec 2004
    Posts
    95
    Maybe try a clean before rebuilding? I don't think you need "generate mapfile" enabled, either.

  3. #3
    RoD
    RoD is offline
    Redundantly Redundant RoD's Avatar
    Join Date
    Sep 2002
    Location
    Missouri
    Posts
    6,331
    I assume you're using a version of VC++ that supports profiling?

  4. #4
    Software Developer jverkoey's Avatar
    Join Date
    Feb 2003
    Location
    University of Waterloo
    Posts
    1,903
    I have this same problem with my visual studio, I've never been able to figure out how to get it to do profiling...I'm using VC++ 6.0 Professional edition...so I don't really know why it's not working.

  5. #5
    RoD
    RoD is offline
    Redundantly Redundant RoD's Avatar
    Join Date
    Sep 2002
    Location
    Missouri
    Posts
    6,331
    The profiler always worked for me right out of the box, but there could be a significant difference between the Professional edition and the Enterprise edition.

  6. #6
    Registered User Codeplug's Avatar
    Join Date
    Mar 2003
    Posts
    4,674
    Only the Professional and Enterprise editions support profiling.

    gg

  7. #7
    Registered User
    Join Date
    Mar 2003
    Posts
    580
    Maybe try a clean before rebuilding? I don't think you need "generate mapfile" enabled, either.
    I did, actually

    I assume you're using a version of VC++ that supports profiling?
    Yep, I've got it to work before

    I have this same problem with my visual studio, I've never been able to figure out how to get it to do profiling...I'm using VC++ 6.0 Professional edition...so I don't really know why it's not working.
    It's an exceptionally useful tool...if I do get it to work, I will send you a private message telling how. I don't know if I have enterprise or professional...I only know I've got a version that supports profiling.
    As a sidenote jverkoey, if you are stuck for a profiler, you can look into the demo version of the intel vtune C++ compiler

  8. #8
    Registered User Codeplug's Avatar
    Join Date
    Mar 2003
    Posts
    4,674
    According to the oracle (google), this seems to be a fairly common problem.

    http://support.microsoft.com/default...;EN-US;Q224382

    gg

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. how to compile projects ?
    By manzoor in forum C++ Programming
    Replies: 31
    Last Post: 10-15-2008, 11:52 AM
  2. C++ std routines
    By siavoshkc in forum C++ Programming
    Replies: 33
    Last Post: 07-28-2006, 12:13 AM
  3. Errors with including winsock 2 lib
    By gamingdl'er in forum C++ Programming
    Replies: 3
    Last Post: 12-05-2005, 07:13 PM
  4. pointer to array of objects of struct
    By undisputed007 in forum C++ Programming
    Replies: 12
    Last Post: 03-02-2004, 03:49 AM
  5. Using 'if' with char arrays or string objects
    By c++_n00b in forum C++ Programming
    Replies: 36
    Last Post: 06-06-2002, 09:04 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21