Problem with dev-c++

This is a discussion on Problem with dev-c++ within the C++ Programming forums, part of the General Programming Boards category; Not sure if this is right forum but you can move it. Anyways we just re-formated and stuff, and now ...

  1. #1
    Registered User
    Join Date
    Aug 2004
    Posts
    731

    Problem with dev-c++

    Not sure if this is right forum but you can move it.

    Anyways we just re-formated and stuff, and now I just re-downloaded dev-c++ and installed it...

    But when I go to compile it, it says it could not run. That is all the info I can give and I have.

    Anyone have any ideas this time?

  2. #2
    Registered User
    Join Date
    Aug 2004
    Posts
    6
    Did you make sure you installed the version with the Mingw compiler?

  3. #3
    Registered User
    Join Date
    Aug 2004
    Posts
    731
    Let me check...

  4. #4
    Registered User
    Join Date
    Aug 2004
    Posts
    731
    Nope I didn't I'm on a 56k modem and went the cheap way. Thanks for your help.

  5. #5
    Registered User
    Join Date
    Aug 2004
    Posts
    731
    OK it still didn't work when I got the one wiht that one feature you said.

    Here is what the Compiler box says:

    2 C:\Documents and Settings\Alex\Desktop\2 unable to run program file.


    Here is what the compiler log says:

    Compiler: Default compiler
    Executing g++.exe...
    g++.exe "C:\Documents and Settings\Alex\Desktop\test.cpp" -o "C:\Documents and Settings\Alex\Desktop\test.exe" -I"C:\Documents and Settings\Alex\Desktop\Dev-Cpp\include\c++\3.3.1" -I"C:\Documents and Settings\Alex\Desktop\Dev-Cpp\include\c++\3.3.1\mingw32" -I"C:\Documents and Settings\Alex\Desktop\Dev-Cpp\include\c++\3.3.1\backward" -I"C:\Documents and Settings\Alex\Desktop\Dev-Cpp\lib\gcc-lib\mingw32\3.3.1\include" -I"C:\Documents and Settings\Alex\Desktop\Dev-Cpp\include" -L"C:\Documents and Settings\Alex\Desktop\Dev-Cpp\lib"
    Execution terminated


    Any ideas?

  6. #6
    Registered User
    Join Date
    Aug 2004
    Posts
    193
    ^^^Exactly what I got, so I downgraded to 4.0 and it works perferctly

  7. #7
    Registered User
    Join Date
    Aug 2004
    Posts
    731
    alright guess I'll donwgrade but ever sence we re-formated 1 day ago stuff that worked before isn't owrking now... :'(

  8. #8
    C++ Witch laserlight's Avatar
    Join Date
    Oct 2003
    Location
    Singapore
    Posts
    20,968
    Have you read this FAQ?
    In particular, the unable to run program file item.

    In any case, make sure you do the uninstall/reinstall jig properly, and avoid spaces in paths as far as possible.

    Also, do not downgrade, unless you prefer using the outdated GCC 2.95 instead of GCC 3.3.1, which comes with Dev-C++ 4.9.9.0
    C + C++ Compiler: MinGW port of GCC
    Version Control System: Bazaar

    Look up a C++ Reference and learn How To Ask Questions The Smart Way

  9. #9
    Registered User
    Join Date
    Aug 2004
    Posts
    731
    I got no choice. I am good at computers so I didn't notin worng that I recall. But I will try 4.9.9.0 one more time before I use 4.0.

  10. #10
    Registered User
    Join Date
    Aug 2004
    Posts
    731
    PLEASE help me I need dev 4.9.9.0 because I just can't use 4.0!

    PLEASE help me!

  11. #11
    VA National Guard The Brain's Avatar
    Join Date
    May 2004
    Location
    Manassas, VA USA
    Posts
    903

    Question

    are you into playing runescape by any chance... rune hunter
    • "Problem Solving C++, The Object of Programming" -Walter Savitch
    • "Data Structures and Other Objects using C++" -Walter Savitch
    • "Assembly Language for Intel-Based Computers" -Kip Irvine
    • "Programming Windows, 5th edition" -Charles Petzold
    • "Visual C++ MFC Programming by Example" -John E. Swanke
    • "Network Programming Windows" -Jones/Ohlund
    • "Sams Teach Yourself Game Programming in 24 Hours" -Michael Morrison
    • "Mathmatics for 3D Game Programming & Computer Graphics" -Eric Lengyel

  12. #12
    Registered User
    Join Date
    Aug 2004
    Posts
    731
    Well it's not helping me...but I used to be. (everyone askes that!) And NO I did NOT get this name by runescape. I played a game called Tibia (www.tibia.com) and they had lots o runes in that game (basicly what a sorcerer and druid is) and so I wanted a sorcerer in that game to make runes (hmm(heavy magic missile,sd)(suden death)) for my knight wich is named Fast Hunter (He was my first character in Tibia). So I had to think of a nice original name. So I got Rune Hunter. Soon I developed a story about a character named Rune Hunter. It started as a Tibia story but then ended up as a non Tibia story about Rune Hunter ruleing the Universe so on...

    There you go the whole story almost...

  13. #13
    Sweet
    Join Date
    Aug 2002
    Location
    Tucson, Arizona
    Posts
    1,801
    Just to let you know dev does not like to be installed in folders like My Documents try installing it in C:\Dev-C++. As For those errors they look like the backwards warning perhaps your using <iostream.h> instead of <iostream>
    Woop?

  14. #14
    Registered User
    Join Date
    Aug 2004
    Posts
    193
    Quote Originally Posted by laserlight
    Have you read this FAQ?
    In particular, the unable to run program file item.

    In any case, make sure you do the uninstall/reinstall jig properly, and avoid spaces in paths as far as possible.

    Also, do not downgrade, unless you prefer using the outdated GCC 2.95 instead of GCC 3.3.1, which comes with Dev-C++ 4.9.9.0
    I tried everything you told me and it STILL DOESN'T work. I guess 4.0 will do me until 5.0 is released.

  15. #15
    Registered User
    Join Date
    Aug 2004
    Posts
    193
    Quote Originally Posted by prog-bman
    As For those errors they look like the backwards warning perhaps your using <iostream.h> instead of <iostream>
    I thought it was more proper to use <iostream.h>, so that's probably why 4.9.9.0 isn't working for me. Anyway, thanks for the info.

Page 1 of 2 12 LastLast
Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Laptop Problem
    By Boomba in forum Tech Board
    Replies: 1
    Last Post: 03-07-2006, 05:24 PM
  2. Replies: 5
    Last Post: 11-07-2005, 10:34 PM
  3. Problem running prog I wrote in Dev C++
    By KidMan in forum C Programming
    Replies: 8
    Last Post: 09-22-2005, 01:50 AM
  4. searching problem
    By DaMenge in forum C Programming
    Replies: 9
    Last Post: 09-12-2005, 01:04 AM
  5. half ADT (nested struct) problem...
    By CyC|OpS in forum C Programming
    Replies: 1
    Last Post: 10-26-2002, 08:37 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21