allegro help

This is a discussion on allegro help within the C++ Programming forums, part of the General Programming Boards category; file is too big too attach......go here and get msvcmake: http://www.allegro.cc/files/...

  1. #16
    Unregistered Leeman_s's Avatar
    Join Date
    Oct 2001
    Posts
    753
    file is too big too attach......go here and get msvcmake:

    http://www.allegro.cc/files/

  2. #17
    Registered User
    Join Date
    Sep 2002
    Posts
    34
    k thx dling now i had to reinstall because i just found out adding libraries and header files from different compilers doesnt help
    Compiler: MSVC++ 6.0

  3. #18
    Unregistered Leeman_s's Avatar
    Join Date
    Oct 2001
    Posts
    753
    and make sure you link alleg.lib: project > settings > link tab

  4. #19
    Registered User
    Join Date
    Sep 2002
    Posts
    34
    ok both errors are gone but i have one now i removed the 0 from
    Code:
    return(0);
    now i have this error

    --------------------Configuration: frog2 - Win32 Debug--------------------
    Compiling...
    frog2.cpp
    C:\Program Files\Microsoft Visual Studio\MyProjects\frog\frog2.cpp(12) : error C2059: syntax error : ')'
    Error executing cl.exe.

    frog2.exe - 1 error(s), 0 warning(s)

    Code:
    #include <iostream>
    #include <conio.h>
    #include <allegro.h>
    using namespace std;
    
    int main(int argc, char *argv[]) 
    {
    	allegro_init();
    	install_keyboard();
    	set_gfx_mode(GFX_AUTODETECT, 640,480,0,0); 
    	readkey();
    	return();
    }
    END_OF_MAIN();
    Last edited by Goku-ssj; 09-15-2002 at 12:29 PM.
    Compiler: MSVC++ 6.0

  5. #20
    moi
    moi is offline
    Registered User moi's Avatar
    Join Date
    Jul 2002
    Posts
    946
    main returns an int. either return 0; or return (0); is acceptable.
    hello, internet!

  6. #21
    Registered User
    Join Date
    Sep 2002
    Posts
    34
    this is really confusing more errors to solve

    Code:
    #include <iostream>
    #include <conio.h>
    #include <allegro.h>
    using namespace std;
    
    int main(int argc, char *argv[]) 
    {
    	allegro_init();
    	install_keyboard();
    	set_gfx_mode(GFX_AUTODETECT, 640,480,0,0); 
    	readkey();
    	return 0;
    
    }
    END_OF_MAIN();
    --------------------Configuration: frog2 - Win32 Debug--------------------
    Compiling...
    frog2.cpp
    Linking...
    LIBCD.lib(crt0.obj) : error LNK2001: unresolved external symbol _main
    Debug/frog2.exe : fatal error LNK1120: 1 unresolved externals
    Error executing link.exe.

    frog2.exe - 2 error(s), 0 warning(s)
    Compiler: MSVC++ 6.0

  7. #22
    moi
    moi is offline
    Registered User moi's Avatar
    Join Date
    Jul 2002
    Posts
    946
    what you mean "more errors"? that's the same error you started out with!
    hello, internet!

  8. #23
    Registered User
    Join Date
    Sep 2002
    Posts
    34
    hey atleast your post count is going up
    Compiler: MSVC++ 6.0

  9. #24
    moi
    moi is offline
    Registered User moi's Avatar
    Join Date
    Jul 2002
    Posts
    946
    Originally posted by Goku-ssj
    hey atleast your post count is going up
    yeah, i was worried at first that it might not be
    hello, internet!

  10. #25
    Registered User
    Join Date
    Sep 2002
    Posts
    34
    i went to the allegro.cc forum and someone was talking about an mscv fix file would that help me and if it would where can i get it?
    Compiler: MSVC++ 6.0

  11. #26
    moi
    moi is offline
    Registered User moi's Avatar
    Join Date
    Jul 2002
    Posts
    946
    Originally posted by Goku-ssj
    i went to the allegro.cc forum and someone was talking about an mscv fix file would that help me and if it would where can i get it?
    if they were talking about it, then ask them exactly what it is and where to get it
    hello, internet!

  12. #27
    Unregistered Leeman_s's Avatar
    Join Date
    Oct 2001
    Posts
    753
    when you installed allegro, did it go through a 10 second or so process and then tell you that it installed successfully? if not, its still not installed correctly.

    did you go through those 4 steps i wrote quite a few posts up?

  13. #28
    Registered User
    Join Date
    Sep 2002
    Posts
    34
    YEAH ITS FIXED for some reason i was using console applications and not regular win32 applications anyway i can start using allegro and thanks for all your help through this agonizing process
    Compiler: MSVC++ 6.0

Page 2 of 2 FirstFirst 12
Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Allegro in C for a newb
    By Ideius in forum C Programming
    Replies: 5
    Last Post: 12-29-2005, 04:36 PM
  2. Game Programming FAQ
    By TechWins in forum Game Programming
    Replies: 5
    Last Post: 09-29-2004, 03:00 AM
  3. double buffering for allegro
    By Leeman_s in forum C++ Programming
    Replies: 6
    Last Post: 09-12-2002, 03:45 PM
  4. Special Allegro Information
    By TechWins in forum Game Programming
    Replies: 12
    Last Post: 08-21-2002, 12:35 AM
  5. Allegro programming in a window
    By Person Man in forum Windows Programming
    Replies: 0
    Last Post: 11-16-2001, 03:23 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21