__asm don't work

This is a discussion on __asm don't work within the C++ Programming forums, part of the General Programming Boards category; When i'am putting an assembler code in C++ like __asm { } and calling some of int 13h(I use only ...

  1. #1
    Registered User
    Join Date
    Jun 2002
    Posts
    4

    Angry __asm don't work

    When i'am putting an assembler code in C++ like

    __asm
    {



    }

    and calling some of int 13h(I use only BIOS INT in windows applications) and it won't work, works only INT 3, but other functions(int 13h......) don't. Commands MOV,XOR...... works correct.
    I use W2k, may be it is the problem, but as Administrator.
    What is the problem???
    I copied form help file code that generates a system beep and pasted it into .cpp. I tried it in BC5 and in MSVC6, works only under BC nor in MSVC, when creating DOS app, but if it's created as win app, it don't work in both,

  2. #2
    Registered User
    Join Date
    Sep 2001
    Posts
    305
    theres no such thing as a bios 13h interrupt. the correct way to use hex numbers is with the 0x prefix: 0x13.

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. strcmp returning 1...
    By Axel in forum C Programming
    Replies: 12
    Last Post: 09-08-2006, 08:48 PM
  2. getline() don't want to work anymore...
    By mikahell in forum C++ Programming
    Replies: 7
    Last Post: 07-31-2006, 11:50 AM
  3. Why don't the tutorials on this site work on my computer?
    By jsrig88 in forum C++ Programming
    Replies: 3
    Last Post: 05-15-2006, 11:39 PM
  4. fopen();
    By GanglyLamb in forum C Programming
    Replies: 8
    Last Post: 11-03-2002, 12:39 PM
  5. DLL __cdecl doesnt seem to work?
    By Xei in forum C++ Programming
    Replies: 6
    Last Post: 08-21-2002, 05:36 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21