Like Tree5Likes

"projet-Debug" uses an invalid compiler

This is a discussion on "projet-Debug" uses an invalid compiler within the C++ Programming forums, part of the General Programming Boards category; While compiling, Codeblocks says :"projet-Debug uses an invalid compiler. Probably the toolchain path within the compiler options is not setup ...

  1. #1
    Registered User
    Join Date
    Feb 2013
    Posts
    54

    "projet-Debug" uses an invalid compiler

    While compiling, Codeblocks says :"projet-Debug uses an invalid compiler. Probably the toolchain path within the compiler options is not setup correctly?! Skipping..."

    (projet is the name of my project)

    Thank you in advance for your help because i don't understand, my selected compiler when i go in Settings6Compiler and Debugger is GNU GCC Compiler

  2. #2
    Registered User
    Join Date
    Jun 2011
    Posts
    2,066
    Did you try searching the internet for this error message?

    c++ - Invalid toolchain error with Code::Blocks - Stack Overflow
    ... uses an invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!]

    @mods, sounds like this thread might be better suited for the tech forum.

  3. #3
    Registered User
    Join Date
    Feb 2013
    Posts
    54
    Yes I searched an answer on the internet but when i do what is said on the links you just gave, i mean when i go to Settings->Compiler and Debugger->ToolChain Executables ->Click Auto Detect on the compiler's installation directory

    nothing changes, the same error message is displayed

  4. #4
    Registered User
    Join Date
    Feb 2013
    Posts
    54
    does anyone have an idea?

  5. #5
    Registered User
    Join Date
    Jun 2011
    Posts
    2,066
    Do you definitely have the compiler installed (and not just the IDE)?
    Did you try "Reset Defaults" on the same window?

  6. #6
    Registered User
    Join Date
    Feb 2013
    Posts
    54
    Thank you for your advices. I don't know for sure if i have the compiler installed.
    All i can say is that what is displayed is :

    Selected Compiler : GNU GCC Compiler


    Toolchain executables :
    Compiler's installation directory :
    C:\MinGW

    I also tried "Reset Defaults" as you said but the same error message is displayed

  7. #7
    Registered User
    Join Date
    Feb 2013
    Posts
    54
    Does anyone have another idea?

  8. #8
    Registered User
    Join Date
    May 2009
    Posts
    2,372
    Quote Originally Posted by funnydarkvador View Post
    Does anyone have another idea?
    Yes, Install a compiler!!

    Then use that compiler; after setting up Code::Blocks to use it!

    Else, find a compiler on your computer and set Code::Blocks to use it.

    There are NO other options to get Code::Blocks to work!

    Tim S.
    Matticus likes this.
    "Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the universe trying to produce bigger and better idiots. So far, the Universe is winning." Rick Cook

  9. #9
    Registered User
    Join Date
    Feb 2013
    Posts
    54
    I think it may exist another solution, don't you? And if i install a compiler, which one must i choose ? (i have Vista on my computer)
    Thanks

  10. #10
    Registered User
    Join Date
    Feb 2013
    Posts
    54
    Please I need help!!

  11. #11
    Registered User
    Join Date
    Jun 2011
    Posts
    2,066
    There's really not much else we can do for you.
    What OS are you running?

  12. #12
    Registered User
    Join Date
    Feb 2013
    Posts
    54
    I'm running Vista. Thank you nevertheless

  13. #13
    Registered User
    Join Date
    Jun 2011
    Posts
    2,066
    Did you download/install the "codeblocks-##.##-setup.exe" or the "codeblocks-##.##mingw-setup.exe"?

  14. #14
    Registered User
    Join Date
    Feb 2013
    Posts
    54
    i exactly downloaded codeblocks-10.05-setup.exe

  15. #15
    Registered User
    Join Date
    Jun 2011
    Posts
    2,066
    That version doesn't include the compiler. I'd recommend you uninstall it, and download "codeblocks-##.##mingw-setup.exe" (the current version appears to be 12.11).
    stahta01 and Salem like this.

Page 1 of 2 12 LastLast
Popular pages Recent additions subscribe to a feed

Similar Threads

  1. compiler's "debug" configuration
    By Bleech in forum C Programming
    Replies: 1
    Last Post: 01-13-2007, 03:26 AM
  2. Replies: 2
    Last Post: 09-12-2006, 04:50 AM
  3. Replies: 0
    Last Post: 04-21-2006, 01:41 PM
  4. "itoa"-"_itoa" , "inp"-"_inp", Why some functions have "
    By L.O.K. in forum Windows Programming
    Replies: 5
    Last Post: 12-08-2002, 07:25 AM
  5. "CWnd"-"HWnd","CBitmap"-"HBitmap"...., What is mean by "
    By L.O.K. in forum Windows Programming
    Replies: 2
    Last Post: 12-04-2002, 06:59 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21