Seems like you guys are struggling hard to invent terminology that already exists. See for instance the concepts:
and probably others.
Elysia's "range iterator which can walk forwards and backwards" is a BidirectionalIterator.
Also, using the word "range" produces confusion because boost already has a range concept, which is not really related to what you guys are talking about.