Boost::filesystem does not work in windows

This is a discussion on Boost::filesystem does not work in windows within the C++ Programming forums, part of the General Programming Boards category; Hello all does someone using boost::filesystem in windows and manage to make it work ? i just can't make it ...

  1. #1
    Registered User
    Join Date
    Mar 2008
    Posts
    58

    Boost::filesystem does not work in windows

    Hello all
    does someone using boost::filesystem in windows and manage to make it work ?
    i just can't make it to recognize the paths in windows for example if i have this code with
    Code:
    directory that does exists :
    
    boost::filesystem::path path("D:\\downloads\\",native); 
    
    if(boost::filesystem::exists(path)){
    
        printf("is");
    
    }else{
    
        printf("none");
    
    }
    the directory does exists but i always getting the printf("none");

  2. #2
    and the hat of sweating
    Join Date
    Aug 2007
    Location
    Toronto, ON
    Posts
    3,545
    Have you tried replacing the "\\" with "/" in your string?
    Either that or remove the trailing "//" in the directory name.
    That's all I can think of right now.

  3. #3
    Registered User
    Join Date
    Mar 2008
    Posts
    58
    yes i did it all

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. The Bludstayne Open Works License
    By frenchfry164 in forum A Brief History of Cprogramming.com
    Replies: 8
    Last Post: 11-26-2003, 10:05 AM
  2. SDL and Windows
    By nickname_changed in forum Windows Programming
    Replies: 14
    Last Post: 10-24-2003, 12:19 AM
  3. Menu Item Caption - /a for right aligned Accelerator?
    By JasonD in forum Windows Programming
    Replies: 6
    Last Post: 06-25-2003, 11:14 AM
  4. Does graphics.h work with windows??
    By sundeeptuteja in forum C++ Programming
    Replies: 6
    Last Post: 09-13-2002, 09:08 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21