I have tried a lot...but this is not working.

This is a discussion on I have tried a lot...but this is not working. within the C Programming forums, part of the General Programming Boards category; >Thx...prelude....but....i figured everything you pointed out before i even checked the post.... Prelude takes the time to go through your ...

  1. #16
    Registered User
    Join Date
    Oct 2001
    Posts
    2,934
    >Thx...prelude....but....i figured everything you pointed out before i even checked the post....

    Prelude takes the time to go through your code piece by piece, and now you say you already figured out everything ... simply amazing.

    How about showing a little gratitude?

  2. #17
    End Of Line Hammer's Avatar
    Join Date
    Apr 2002
    Posts
    6,231
    Originally posted by swoopy
    >Thx...prelude....but....i figured everything you pointed out before i even checked the post....

    Prelude takes the time to go through your code piece by piece, and now you say you already figured out everything ... simply amazing.

    How about showing a little gratitude?
    Sounds all too familiar to me.
    When all else fails, read the instructions.
    If you're posting code, use code tags: [code] /* insert code here */ [/code]

  3. #18
    Senor Member nomi's Avatar
    Join Date
    Jan 2004
    Posts
    129
    Nah....I was a bit surprised at the sudden burst of anger....she knows I cant thank her enough for all the help.....

  4. #19
    Senor Member nomi's Avatar
    Join Date
    Jan 2004
    Posts
    129
    Lolz....sry.....but THANKS A LOT FOR ALL THE HELP....

  5. #20
    Casual Visitor
    Join Date
    Oct 2001
    Posts
    350
    Originally posted by nomi
    Replacement = fgets(buff1,MAXchar,stdin);???

    Are my replacements okay? and
    Why replace gets with fgets???
    Is it bcoz of '\n', coz i have used a much longer way to take them out.....
    You can *try* something like

    Code:
    void stripN(char *in)
    {
          char *p;
    
          if((p = strchr(in, '\n')) != NULL)
              *p = '\0';
    }
    
    .....
    
    stripN(fgets(some_buf, sizeof some_buf, stdin));
    I haven't used a compiler in ages, so please be gentle as I try to reacclimate myself. :P

Page 2 of 2 FirstFirst 12
Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Animation class not working
    By VirtualAce in forum Game Programming
    Replies: 5
    Last Post: 03-02-2005, 05:48 AM
  2. x on upper right corner not working
    By caduardo21 in forum Windows Programming
    Replies: 1
    Last Post: 02-20-2005, 07:35 PM
  3. Replies: 5
    Last Post: 09-19-2004, 06:52 AM
  4. cygwin -> unix , my code not working properly ;(
    By CyC|OpS in forum C Programming
    Replies: 4
    Last Post: 05-18-2002, 04:08 AM
  5. Board Not Working Very Well Today
    By Witch_King in forum A Brief History of Cprogramming.com
    Replies: 2
    Last Post: 08-31-2001, 10:19 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21