Need help with allegro gabber utility. Please!

This is a discussion on Need help with allegro gabber utility. Please! within the C Programming forums, part of the General Programming Boards category; I'm trying to learn allegro and right now I'm trying to create datafiles with the grabber utility. The problem is ...

  1. #1
    Registered User
    Join Date
    Aug 2001
    Posts
    79

    Need help with allegro gabber utility. Please!

    I'm trying to learn allegro and right now I'm trying to create datafiles with the grabber utility. The problem is that I can't get palettes to work properly. I've tried to create a datafile containing a bitmap and a palette that was grabbed from the bitmap file. Then I made a simple program that loads the datafile and shows the image. However the colors are all mixed up.
    What am I doing wrong?

  2. #2
    Registered User
    Join Date
    Nov 2001
    Posts
    1

    Question

    Gabber?

  3. #3
    Unregistered
    Guest
    That's supposed to be "grabber", sorry.

  4. #4
    Linguistic Engineer... doubleanti's Avatar
    Join Date
    Aug 2001
    Location
    CA
    Posts
    2,459
    you need to load the pallete in your program... else it uses the default palette and your color indexes display incorrect colors...
    hasafraggin shizigishin oppashigger...

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Allegro in C for a newb
    By Ideius in forum C Programming
    Replies: 5
    Last Post: 12-29-2005, 03:36 PM
  2. Game Programming FAQ
    By TechWins in forum Game Programming
    Replies: 5
    Last Post: 09-29-2004, 02:00 AM
  3. double buffering for allegro
    By Leeman_s in forum C++ Programming
    Replies: 6
    Last Post: 09-12-2002, 02:45 PM
  4. Special Allegro Information
    By TechWins in forum Game Programming
    Replies: 12
    Last Post: 08-20-2002, 11:35 PM
  5. Replies: 2
    Last Post: 11-26-2001, 03:05 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21