WinDriver

This is a discussion on WinDriver within the C Programming forums, part of the General Programming Boards category; Hi There, Properly a really daft question but i am developing some code and am trouble with one specific function. ...

  1. #1
    Registered User
    Join Date
    Nov 2011
    Posts
    61

    WinDriver

    Hi There,

    Properly a really daft question but i am developing some code and am trouble with one specific function. It contains functions like WD_Open WD_License etc.

    Is there any issue using these functions on a windows 7 professional machine?

    Thanks
    James

  2. #2
    Master Apprentice phantomotap's Avatar
    Join Date
    Jan 2008
    Posts
    4,415
    O_o

    And do you have the library installed?

    And a bazillion other questions I'm not typing out...

    Soma

  3. #3
    Registered User
    Join Date
    Nov 2011
    Posts
    61
    Code:
    //    Open driver
        hWD = INVALID_HANDLE_VALUE ;
        hWD = WD_Open ( ) ;
    
    
        //    Exit if driver not opened
        if ( hWD == INVALID_HANDLE_VALUE )                            return ( 1 ) ;
    
    
        //    Set up version 7 license string
        BZERO ( lic ) ;
        strcpy ( lic.cLicense, "6f1ea8b419")  ;
    
    
        WD_License ( hWD, &lic ) ;
    
    
        //    Get version
        BZERO ( ver ) ;
        WD_Version ( hWD, &ver ) ;
    
    
        //    Exit if version incorrect
        if ( ver.dwVer < WD_VER )                                    return ( 2 ) ;
    is the first part of my code.

    it keeps saying the ver.dwVer = 0, and as a result retuning and not continuing with the code.

    Any ideas as to why?

    The library issue would appear with the above WD_Open wouldnt it?
    Last edited by r_james14; 03-13-2012 at 08:40 AM.

  4. #4
    Technical Lead QuantumPete's Avatar
    Join Date
    Aug 2007
    Location
    London, UK
    Posts
    894
    You should use code tags for posting code
    "No-one else has reported this problem, you're either crazy or a liar" - Dogbert Technical Support
    "Have you tried turning it off and on again?" - The IT Crowd

  5. #5
    Registered User
    Join Date
    Nov 2011
    Posts
    61
    okay i been playing around and the WD License function isnt returning anything, it seems not to be going anything anyone any suggests where to start fault finding.

    It does build but does nothing.

    James

  6. #6
    Registered User
    Join Date
    Nov 2011
    Posts
    61
    is it possible that i am using a 64bit machine be the problem?

  7. #7
    a_capitalist_story
    Join Date
    Dec 2007
    Posts
    2,655
    Well, if it's this function, then a good read of the documentation there tells you:

    RETURN VALUE

    Returns WD_STATUS_SUCCESS (0) on success, or an appropriate error code otherwise [A].
    What is it returning? You say it "isn't returning anything", but I find that highly unlikely.

  8. #8
    Registered User
    Join Date
    Nov 2011
    Posts
    61
    Code:
    #define WD_License(h,pLicense)\
        WD_FUNCTION(IOCTL_WD_LICENSE, h, pLicense, sizeof (WD_LICENSE), FALSE)
    is the definition of it and when i debug it, all the variables and structures associated with it come back as empty.

  9. #9
    a_capitalist_story
    Join Date
    Dec 2007
    Posts
    2,655
    Maybe you should try their support channels?

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Jungo WinDriver
    By xxxrugby in forum Tech Board
    Replies: 3
    Last Post: 03-30-2005, 01:47 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21