Usually the best coding convention is consistency with surrounding code.
But when you're writing something from scratch, what are some good naming conventions?
- How do you format your variables? E.g. under_score_names, or CamelCase
- Do you use prefixes for structs, pointers or typdefs? E.g. mytype_t, or pMyPointer
- What kind of prefixing do you use to group functions together?