Old PC Checksum Error...

This is a discussion on Old PC Checksum Error... within the A Brief History of Cprogramming.com forums, part of the Community Boards category; Hi, Im trying to repair this old PC casue its mother board had gone. I broght an old one off ...

  1. #1
    Registered User (TNT)'s Avatar
    Join Date
    Aug 2001
    Location
    UK
    Posts
    339

    Angry Old PC Checksum Error...

    Hi,

    Im trying to repair this old PC casue its mother board had gone. I broght an old one off a mate. When i first ran it i got CMOS Battery Failed. So i replaced the battery now i got 2 new errors.

    Flopppy Disk(s) fail (40)
    Keyboard error or no keyboard present
    CMOS Checksum Error - Defaults Loaded

    Now i know the keyboard isnt there, and i cant get my floppy IDE to work but i will fix that somehow. But it never gets past the first screen, the one where it does the memory test, which completes fine, then it dects the drives then i get those errors and it just stops with a flashing input cursor. Is it the checksum error that stops it continuiung to boot? or the floppy or keyboard or somthing else.

    Thanks
    TNT

  2. #2
    Former Member
    Join Date
    Oct 2001
    Posts
    955
    man, those are heavy hardware problems, the checksum thing means that your BIOS is screwed, the disk and keyboard things are a result of that.

    I wish I could help you

    Oskilian

  3. #3
    Linguistic Engineer... doubleanti's Avatar
    Join Date
    Aug 2001
    Location
    CA
    Posts
    2,459
    check the new battery... or reseat it... it could be the bios... maybe you could replace that...
    hasafraggin shizigishin oppashigger...

  4. #4
    _B-L-U-E_ Betazep's Avatar
    Join Date
    Aug 2001
    Posts
    1,412
    Can you get into the BIOS config before it checks your drives?

    And I would recheck the battery too... is it a new one? Are your contacts corroded?

    Try hooking a keyboard to it... some motherboards won't continue without one.
    Blue

  5. #5
    Registered User (TNT)'s Avatar
    Join Date
    Aug 2001
    Location
    UK
    Posts
    339
    Hey,

    It says Press F1 to contiue past these errors, or press del to enter setup. But i aint got an AT keyboard im getting one tommorow though. Is there anyway if i can get into the bios can i uncorrupt it or anything?

    also the battery said it was dead when i first turned it on so i put a new one in now that error has gone.

    Now i just have the keyboard and:

    Cheksum error - defualts loaded....

    Is there anyway i can fix this.

    Thanks
    TNT
    TNT
    You Can Stop Me, But You Cant Stop Us All

  6. #6
    Registered User rick barclay's Avatar
    Join Date
    Aug 2001
    Posts
    835
    I don't think you'll get any further until you fix the floppy and keyboard issues.

    I always thought checksum errors were memory-related. Just
    because the bios is telling you the memory is ok doesn't mean
    it's ok. I know that sounds screwy, but I once had a pc serviced
    for one problem and the guy at the store told me the memory
    stick was bad, too, even though it passed the post.

    rick barclay
    Last edited by rick barclay; 12-01-2001 at 02:17 PM.
    No. Wait. Don't hang up!

    This is America calling!

  7. #7
    _B-L-U-E_ Betazep's Avatar
    Join Date
    Aug 2001
    Posts
    1,412
    >>>It says Press F1 to contiue past these errors, or press del to enter setup. But i aint got an AT keyboard im getting one tommorow though. Is there anyway if i can get into the bios can i uncorrupt it or anything?

    Just get an AT keyboard... like you said. It isn't the bios that is your main problem at this point. If the bios was bad, you wouldn't even get a mem check. If your ram was really bad, it wouldn't even start (exception for what Rick said... which is bad memory blocks).

    Put the keyboard on and tell me what MB, processor, and bios you are using. Though, I have a distinct feeling that putting the keyboard on itself... will solve a lot of your problems here.

    Not having a keyboard at this point is like saying, "how can I fix something that I absolutely have no access to?"
    Blue

  8. #8
    Registered User
    Join Date
    Sep 2001
    Posts
    412
    It's basically telling you that you need to reset all your CMOS settings because the SRAM which held them lost all its information (because the battery was dead).

    Once you have a keyboard, enter BIOS, set everything up, save the config, and you should never get the checksum error anymore. You get it everytime, because although it loads defaults, it's not SAVING that config; so on next boot, you still have the checksum error which is caused by the SRAM holding garbage values.

    Once you have the keybd, I'm betting you rapidly get stuff working.

    A checksum error basically means the SRAM which holds the BIOS settings is filled with garbage data. This *always* happens after you remove all power to the SRAM module, and it's nothing to worry about. If, even after saving good information to the module, it happens, either your SRAM is corrupt (which rarely happens) or the battery isn't supplying power to the SRAM (much more likely). But, as you're unable to save good config info, you don't know if this happens or not.
    Last edited by The V.; 12-01-2001 at 05:02 PM.

  9. #9
    _B-L-U-E_ Betazep's Avatar
    Join Date
    Aug 2001
    Posts
    1,412
    V... you are awesome.
    Blue

  10. #10
    Registered User (TNT)'s Avatar
    Join Date
    Aug 2001
    Location
    UK
    Posts
    339

    Red face Big Problems...

    Hey,

    I got a keyboard and repaired the bios, i got rid of all the boot errors and installed win95. The first time it booted up it does its scan for devices, then it crashes with big bad blue screen of death saying:

    A fatal exception OE as occured at 0137:00f71a79. The current app will be terminated.

    I get that in safe mode as well.

    Any ideas what the hell that is and how i can fix it???

    Thanks
    TNT
    TNT
    You Can Stop Me, But You Cant Stop Us All

  11. #11
    Registered User
    Join Date
    Sep 2001
    Posts
    412
    I take it the HD is old?

    Boot to DOS, do a scandisk and perform a surface scan. If you can't fully install windows, scandisk is available on the Win95 CD under /win95/, similarly on the win98 CD.

    do scandisk c: and you should be good to go; when it asks to do a surface scan, agree.

    Hopefully the problem is a bad sector on the disk, in which case, it's marked as bad, you can reinstall and all should be good. The other big culprit is memory -- it used to be, RAM wasn't always very reliable, and an intermittant error could cause this. Unfortunately, getting replacement 30-pin SIMMs is a challenge; unless you have a machine to strip for parts, or unless the board will accept 72-pin SIMMs, you're gonna need luck to get working RAM.
    Last edited by The V.; 12-03-2001 at 05:35 PM.

  12. #12
    Registered User (TNT)'s Avatar
    Join Date
    Aug 2001
    Location
    UK
    Posts
    339

    Unhappy Arr..

    Hi,

    Thanks for all the help, i have found out that there is a bad cluster on the disk. Although scandisk did jack all about it. I dont think it already found it casue it was already there as soon as the scan past it then it came up to scanning that section and just went stright past it and reported no errors. but that cluster is marked B. Also i got this ram tester proggy and carried out loads of tests on my sims, and it passed them fine. So the only error i can find is on the HDD. Does this mean a new hard drive? or can i fix it somehow, or is this not responsible?

    Thanks
    TNT
    TNT
    You Can Stop Me, But You Cant Stop Us All

  13. #13
    Registered User
    Join Date
    Sep 2001
    Posts
    412
    If it found the error during the scan, it would have marked the cluster as bad -- so you could reinstall, and everything should work.

    Also, sometimes incompatible HW can cause the hardware detection to crash -- try rebooting and seeing if you can get Windows to work.

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Getting an error with OpenGL: collect2: ld returned 1 exit status
    By Lorgon Jortle in forum C++ Programming
    Replies: 6
    Last Post: 05-08-2009, 09:18 PM
  2. Testing some code, lots of errors...
    By Sparrowhawk in forum C Programming
    Replies: 48
    Last Post: 12-15-2008, 04:09 AM
  3. Another syntax error
    By caldeira in forum C Programming
    Replies: 31
    Last Post: 09-05-2008, 02:01 AM
  4. Avoiding Global variables
    By csonx_p in forum Windows Programming
    Replies: 32
    Last Post: 05-19-2008, 01:17 AM
  5. more then 100errors in header
    By hallo007 in forum Windows Programming
    Replies: 20
    Last Post: 05-13-2007, 09:26 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21