Can you guys test my FPS?

This is a discussion on Can you guys test my FPS? within the A Brief History of Cprogramming.com forums, part of the Community Boards category; okay, tested your game... its pretty cool, i like it. it doesnt seem like it is getting 13 fps....it seems ...

  1. #16
    l'Anziano DavidP's Avatar
    Join Date
    Aug 2001
    Location
    Plano, Texas, United States
    Posts
    2,738
    okay, tested your game...

    its pretty cool, i like it.

    it doesnt seem like it is getting 13 fps....it seems faster....huh...i dunno...but the game looks good

    how did you make your particle system that you used for the explosions? i am gonna need a particle system eventually for explosions and blood on my game that i am making....
    My Website

    "Circular logic is good because it is."

  2. #17
    _B-L-U-E_ Betazep's Avatar
    Join Date
    Aug 2001
    Posts
    1,412
    >>>The human eye sees at 16 fps


    That just isn't true. Modern security system applications record video at 30fps. I have recording equipment that I can set to 16fps, and the playback is choppy... I assure you.

    Human eye is realtime. There really isn't an ips or fps. It is calculated as fast as nuerons can transfer data, which is really damn fast.

    No current video equipment can compete with the human eye.
    Blue

  3. #18
    Registered User Commander's Avatar
    Join Date
    Sep 2001
    Posts
    804
    I couldn't play the game, it gave me an error and closed the window, it didn't stop long enough for me to read the second error , but the first error was,

    Loading main graphics file...

    Anyone know how to fix it?
    oh i'm sorry! i didn;t realize my fist was rushing to meet ur face!

    MSN :: commander_android@hotmail.com []*[]

  4. #19
    Banned frenchfry164's Avatar
    Join Date
    Oct 2001
    Posts
    1,552
    it means your tiles.dat file is corrupt

    Did I include the blood spraying with the particle engine on this ver? If I didn't, open up settings.ini and change the first number to one.

    I don't know why, but my computer is SLOW. I play a game called Era Online and I also get 10 FPS on it, and there are people with crappier computers than mine, and they are getting 40 FPS. Anyone know why my computer is getting so low of framerate?

    Did you really like my particle engine? It took me like two days to program it. Here is the prototype:

    void start_particles(int x,int y, int rangex,int rangey, int intensity, int R,int G, int B,int direction, int life,int speed,int special_effects);

    x is the starting point x (duh) and y is the starting y point.

    rangex is the width of it if going up down, and rangey is the width if going left right (I'm going to combine this into one thing later on).

    intensity is how many pixels are going to be part of the effect

    R, G, and B, is the coloration of the particles. If you are doing blood effects, I got a seperate function, mainly to do the content filter (in the full version of it on my comp, you can remove language and gore). That is why the settings.ini's first number MUST be 1 to have the blood spray effects, 0 means gore off.

    Direction is, well, the direction it goes. I set up an enumeration for it, UP, UPLEFT, UPRIGHT, DOWN, DOWNLEFT, DOWNRIGHT, LEFT, RIGHT.

    life is how long on average that the pixels stay before being removed.

    speed is how long on average that the pixels go.

    special_effects is for doing stuff like the thrust behind the player's ship.

    I basically have a linked list for all the pixels, each pixel has it's own struct. I initialize the pixels in start_particles(), by making random numbers for things like speed, life, and stuff, based on the user's specifications in the calling of start_particles(). How I do it, is I make the random number's lowest number the number specified in the calling, and the highest number is the low number +6 (sorry if I confused you). Every frame I call draw_particles, which basically draws all pixels in action, and after drawing it, it does all the movement, then checks if it is the pixel's time to be deleted. If so, it deletes it from the linked list, and scoots the rest of the structs to fill it's space.

    That may be confusing, but I'm bad at explaining things.

    Did you all turn on your sounds, it does have music and SFX too.

    PS: Another trick you can do in the settings.ini is change the resolution to 1024x768. Do this by changing the second number to either 1, or 0 (I forget).

  5. #20
    Banned frenchfry164's Avatar
    Join Date
    Oct 2001
    Posts
    1,552
    oh yeah, if you shoot an enemy twice and it doesn't die, it just stays there, you need a patch I made (it happened on my friend's comp, it's a prob with XP sometimes).

    Here is the controls if you haven't figured them out:

    Enter - Close a dialogue message
    Spacebar - Fire your gun
    Arrow Buttons - Move your ship
    Escape - Close out

    There are also some debugging stuff, that only I can know, hehe.

    And elchulo, you can only kill all the enemies, and then some dialogue somes up, and it returns to windows. For some reason, whenever I quit the game, it comes up with one of those illegal operation dialogue boxes. I think it's because of how I am destroying the allegro datafiles. I'm trying to fix that right now.

    Here is some specification of stuff I use in this:

    * Double-Buffering for flicker reduction
    * MIDI music and WAV sound effects, with support for MOD files, using DirectSound
    * Simple particle engine
    * Mouse support (in my full version that I have, it's just EXTREMELY buggy ATM)
    * Joystick (see above on why I didn't put it in this version
    * 16 Bit Color, perferred to be in 800x600 resolution (I get 6FPS running 1024x768 mode)
    * BMP, and RLE Sprites for graphics
    * Hardware Accelerated DirectDraw
    * Support for goreless mode (I think this is set at default, see my last post on info on how to turn it back on)

  6. #21
    Code Warrior
    Join Date
    Nov 2001
    Posts
    669
    On my machine the game is not running beacuse I don't have allegro installed. Please upload your game again and with the allegro files this time.
    Current projects:
    1) User Interface Development Kit (C++)
    2) HTML SDK (C++)
    3) Classes (C++)
    4) INI Editor (Delphi)

  7. #22
    l'Anziano DavidP's Avatar
    Join Date
    Aug 2001
    Location
    Plano, Texas, United States
    Posts
    2,738
    or you could go to the website he posted in his first post and download allegro yourself....its not that hard...
    My Website

    "Circular logic is good because it is."

  8. #23
    Code Warrior
    Join Date
    Nov 2001
    Posts
    669
    I know that it is not hard. But if he already uploaded a game than he could upload the needed allegro files too.
    Current projects:
    1) User Interface Development Kit (C++)
    2) HTML SDK (C++)
    3) Classes (C++)
    4) INI Editor (Delphi)

  9. #24
    Banned frenchfry164's Avatar
    Join Date
    Oct 2001
    Posts
    1,552
    The reason I didn't include it is because some people already have allegro runtime, and there is no reason for them to download it again.

Page 2 of 2 FirstFirst 12
Popular pages Recent additions subscribe to a feed

Similar Threads

  1. sustring test puzzle
    By WDT in forum C# Programming
    Replies: 3
    Last Post: 06-29-2009, 07:19 AM
  2. Help needed to verify a new on-line C test
    By JanHruska in forum Projects and Job Recruitment
    Replies: 15
    Last Post: 06-20-2009, 06:48 AM
  3. Creating C/C++ Unit Test Cases
    By chiefmonkey in forum C++ Programming
    Replies: 1
    Last Post: 04-28-2009, 08:29 PM
  4. test this game guys
    By actionbasti in forum Game Programming
    Replies: 5
    Last Post: 12-05-2003, 03:05 PM
  5. dramatic decrease in fps
    By DavidP in forum Game Programming
    Replies: 4
    Last Post: 06-27-2002, 09:05 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21